GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV


  VW GTI Forum / VW Rabbit Forum / VW R32 Forum / VW Golf Forum - Golfmkv.com


 
Register
MYGOLF garage
Timeslips
Search
Members List
Search Today's Posts Mark Forums Read



Go Back   VW GTI Forum / VW Rabbit Forum / VW R32 Forum / VW Golf Forum - Golfmkv.com > Technical Discussions > Engine / Drivetrain / Exhaust



Reply
 
Thread Tools
Old 07-21-2019, 08:51 PM   #1
NC09gti
Go Kart Newbie
 
Drives: 06 GTI DM K04+
Join Date: Oct 2008
Location: High Point, NC
Posts: 26
Codes p0089 and p2293

Hey y'all, today I started get random power loss/fuel cuts after driving for 2hrs on the hwy. It would loose power for a second then back to normal. It was 98°outside. It idles fine and did not though codes. I still plugged in obd2 reader and got 2 pending codes.

P0089 suction control valve stuck
P2293 Fuel pressure regulator 2 performance

Recent maintenance I've done:
Fuel filter 2mths ago
Spark plugs 1mth ago

06 GTI w/156k miles
My mods:
Since 96k miles-
K04 DM+tune
FBOs
Apr intercooler

Since 122k miles-(had to replace due to cam follower)
HPFP with autotech Hi-Volume Fuel Pump Upgrade Kit

I can't find a definite answer on what the problem is after searching, could be Lpfp, n76 valve, coil packs, fuel filter or just the extreme heat. Any ideas?

Last edited by NC09gti; 07-22-2019 at 05:13 AM.
NC09gti is offline   Reply With Quote
Old 07-22-2019, 09:06 AM   #2
Cjpolokid
Autocross Champion
 
Cjpolokid's Avatar
 
Drives: White and black
Join Date: Sep 2017
Location: New York
Posts: 113
It basically told you wats wrong


Sent from my iPhone using Tapatalk
Cjpolokid is offline   Reply With Quote
Old 09-14-2019, 05:23 AM   #3
penance
Fakinsupa
 
penance's Avatar
 
Drives: '07 GTI BMP 2DR
Join Date: Apr 2007
Location: BC West Coast
Posts: 457
Quote:
Originally Posted by NC09gti View Post
Hey y'all, today I started get random power loss/fuel cuts after driving for 2hrs on the hwy. It would loose power for a second then back to normal. It was 98°outside. It idles fine and did not though codes. I still plugged in obd2 reader and got 2 pending codes.

P0089 suction control valve stuck
P2293 Fuel pressure regulator 2 performance

Recent maintenance I've done:
Fuel filter 2mths ago
Spark plugs 1mth ago

06 GTI w/156k miles
My mods:
Since 96k miles-
K04 DM+tune
FBOs
Apr intercooler

Since 122k miles-(had to replace due to cam follower)
HPFP with autotech Hi-Volume Fuel Pump Upgrade Kit

I can't find a definite answer on what the problem is after searching, could be Lpfp, n76 valve, coil packs, fuel filter or just the extreme heat. Any ideas?
Did you figure this out?

I had exact same issue today driving around in 105-115f heat. Left car to sit for hours until mall closed, then drove home without issue.
penance is offline   Reply With Quote
Old 09-18-2019, 05:11 PM   #4
NC09gti
Go Kart Newbie
 
Drives: 06 GTI DM K04+
Join Date: Oct 2008
Location: High Point, NC
Posts: 26
Quote:
Originally Posted by penance View Post
Did you figure this out?

I had exact same issue today driving around in 105-115f heat. Left car to sit for hours until mall closed, then drove home without issue.
It definitely was the heat. The lpfp control module gets overheated and causes fuel cuts. After research I found someone in this forum that sales extension harnesses for the module which should stop the fuel cuts.
Click the link

https://www.golfmkv.com/forums/showthread.php?t=189901

I haven't fixed the module on my gti cause it's not my daily. Hope this helps
NC09gti is offline   Reply With Quote
Old 09-28-2019, 03:39 AM   #5
penance
Fakinsupa
 
penance's Avatar
 
Drives: '07 GTI BMP 2DR
Join Date: Apr 2007
Location: BC West Coast
Posts: 457
Quote:
Originally Posted by NC09gti View Post
It definitely was the heat. The lpfp control module gets overheated and causes fuel cuts. After research I found someone in this forum that sales extension harnesses for the module which should stop the fuel cuts.

Click the link



https://www.golfmkv.com/forums/showthread.php?t=189901



I haven't fixed the module on my gti cause it's not my daily. Hope this helps
Yeah I found his thread too. I ended up buying new pump and control harness (latest revisions) which seemed to fix my issue and let me continue/finish my trip around Arizona. New controller has a steel plate on one side, vs my old entirely encased plastic one. Which although it still gets hot, seems to disappate the heat well enough to prevent the cuts from happening. Debating ordering an extension still, but I am rarely in climates near that heat for the 12yrs I've had the car now, so new module is probably good enough for my situation.

Sent from my GM1917 using Tapatalk
penance is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.