GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Revo Select Plus problem...HELP!!

Project337

Go Kart Champion
Location
North Jersey
Car(s)
07 GTI & 06 Lexus IS
I just picked up a Revo Select Plus and am having a very hard time getting it to connect to my ECU.

Here is some back ground...

I installed the program with the Microsoft .Net V2.0 and then installed the Select Software.

I can launch the software and it will recognize the Switch and I can set my custom classes (A,B,C,) to what ever I want and it will save to the Switch.

I can plug the switch (Stand alone) in the OBD port and the car will see it as I’m getting the 3 beeps. (I tried putting it into lockout mode, works fine, can turn it off, etc)

My problem is, when I have the Switch connect to the laptop and connect it to the OBD port, and Click "Acquire" to see what the chip is set to it ERRORS out. I get "Check Connection to ECU or Protocol Error".

Any ideas as to why this is happening? I really appreciate the help.


Vito.
 

Widebody MkVer

Performance Infused Style
Location
Selden NY
switch the USB port your connecting to.
 

staulkor

V-Dubber
Location
Tempe, Arizona
Car(s)
VW GTI MkV Fahrenhei
There is a bug with the software and it does not work. Trust me, I have tried a lot and my dealer has tried and all we can come up with is that there is a bug.

You are not alone :p
 

bcze1

You people make me laugh
There is a bug with the software and it does not work. Trust me, I have tried a lot and my dealer has tried and all we can come up with is that there is a bug.

You are not alone :p

It's not a bug if the software. Its a hardware issue, as VW has continually updated MkV ECU's. This is a problem on pretty much all mid 2007 and newer MkV's and REVO.

But the good news is it doesn't matter. As you've already discovered the switch works just fine by itself. Program the SPS's settings with your computer and use it as a standalone. Only thing you miss out on is impressing your friends when you press "acquire" on your laptop.
 

Project337

Go Kart Champion
Location
North Jersey
Car(s)
07 GTI & 06 Lexus IS
It's not a bug if the software. Its a hardware issue, as VW has continually updated MkV ECU's. This is a problem on pretty much all mid 2007 and newer MkV's and REVO.

But the good news is it doesn't matter. As you've already discovered the switch works just fine by itself. Program the SPS's settings with your computer and use it as a standalone. Only thing you miss out on is impressing your friends when you press "acquire" on your laptop.

LOL.

Ok so Im not the only one.

I spoke with someone at Revo this morning, he tried to help but didnt really know how. I mean if im not the only one having this problem, then at least i know its not me or the switch.

Thanks for all the help
 

Blocko

Rabblerouser
Location
Vancouver, BC
Bug in the software, mine does the same thing as well.
 

bulldogger

Going for broke
Location
Hawaii
Going to order my SPS here soon. Will let you know. But here is something interesting I experienced... I had my REVO Stg 2 installed by the only REVO dealer in Hawaii (TAI FTW!), and he showed me the REVO GUI on the laptop and my new settings. Had a friend, at a GTG later that week, try to use his SPS to check out my settings and it would not communicate with my ECU. ??? BTW I drive an '08 GTI, the switch worked fine on his '07 GTI, and the switch was bought from the same local dealer.

....any ideas?
 

Project337

Go Kart Champion
Location
North Jersey
Car(s)
07 GTI & 06 Lexus IS
Im an 07 also, got it in July of 07. Dont know if that makes a diff.

I was thinking there was something wrong with my switch or my car, but it seems like a common problem.


Vito.
 

bcze1

You people make me laugh
....any ideas?


Quite simply the dealer uses a slightly different interface than the SPS+. Its a common problem with mid 2007 and later cars. My 2007 GTI, built in Dec 2006 could not communicate with my laptop. But as I said above, it doesn't matter. Just program the SPS+ with the custom settings you want, then plug it in as a stand alone and it will work just fine. You're not losing out on anything important.

SPS switches are designed to work with different cars on different platforms, and between them all VAG & Porsche continually update the ECU's, which makes it tough to keep the SPS hardware compatiable as well. But the software itself is fine, and the SPS works perfectly as a stand alone.
 

Project337

Go Kart Champion
Location
North Jersey
Car(s)
07 GTI & 06 Lexus IS
Quite simply the dealer uses a slightly different interface than the SPS+. Its a common problem with mid 2007 and later cars. My 2007 GTI, built in Dec 2006 could not communicate with my laptop. But as I said above, it doesn't matter. Just program the SPS+ with the custom settings you want, then plug it in as a stand alone and it will work just fine. You're not losing out on anything important.

SPS switches are designed to work with different cars on different platforms, and between them all VAG & Porsche continually update the ECU's, which makes it tough to keep the SPS hardware compatiable as well. But the software itself is fine, and the SPS works perfectly as a stand alone.

Thanks, why couldnt they just tell me when i called Revo. LOL
 

Robin @ Revo

New member
Location
Buford, GA
We did tell you that :)

We had to update our firmware in the SPS switches to work with the newer ECUs. If you would like me to update your switch, send me a PM and you can ship it to us, I can turn it around in a day for you.

Unfortunately when VW updates these cars with new programming, sometimes it throws us for a loop with existing hardware. The new SPS switches shipping now work fine with the newer type ECUs.

Thanks!
 
Top