GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Rear Wiper Does Not Work (2007 BPY)

Hamad990

Passed Driver's Ed
Location
Winnipeg, Manitoba
Car(s)
2007 Golf GTi
Hello,
I've been having trouble with getting my rear wiper to work, and since winter is coming soon I thought I should look into it. I don't really know much about what could be the cause but here's some things I noticed

- The wiper does not work, but the washer fluid works, not sure if they're related.
- When reversing with the front wipers activated, I hear some noises as if there's a mechanism clicking to automatically activate the rear wiper, but nothing happens. I used to hear this noise when the wiper still worked, but now it doesn't and the sound is still there.

Any suggestions as to where I should start?
Any help is appreciated but please don't suggest a wiper delete, I'd like to keep mine for the winter
 

GTI's

Drag Race Newbie
Location
MD
Did you check the fuse, SC41 driver side dash fuse panel. Have a proper scan tool run a scan see if you have any Dtc for rear wiper. Any other issues with the rear hatch functions? These cars have been known to get breaks in the wiring inside the hatch to body rubber boots.
 

Hamad990

Passed Driver's Ed
Location
Winnipeg, Manitoba
Car(s)
2007 Golf GTi
Did you check the fuse, SC41 driver side dash fuse panel. Have a proper scan tool run a scan see if you have any Dtc for rear wiper. Any other issues with the rear hatch functions? These cars have been known to get breaks in the wiring inside the hatch to body rubber boots.
Did not look at the fuse, but my OBDELEVEN did not give me any codes related to the wiper anyways. As for the other functions it’s only the wiper that stopped working. Washer nozzle, tail lights, and hatch opener (or whatever it’s called) all work
 

GTI's

Drag Race Newbie
Location
MD
I do not see any output test for the rear wiper motor like you can find for the front wiper motor. You can at least test the function of the rear wiper switch in the stalk from the steering wheel module 16-measuring blocks 08-group 002-field 3, it will show Not.oper/ activated
 

Hamad990

Passed Driver's Ed
Location
Winnipeg, Manitoba
Car(s)
2007 Golf GTi
GTI's
It shows up as activated when I flick the switch, and I tried it as well without using the fuse (which is ok BTW) and nothing changed. Could it just be the motor that needs replacing?
 

GTI's

Drag Race Newbie
Location
MD
Yes it could be the motor or the wiring to the motor/ module. The switch positions of wiper switch E are sent directly to the steering column electronics control unit J527 and then via the convenience CAN data bus to the onboard supply control unit J519. The onboard supply control unit passes on information about the selected wiper stage to rear wiper module/motor. Power is coming from SC41 to location on WD [41] and down to Pin T4u/4 on the motor. I would be checking for power at that pin at the motor.




 
Last edited:

Hamad990

Passed Driver's Ed
Location
Winnipeg, Manitoba
Car(s)
2007 Golf GTi
Ok, I'm not good with wiring and electricity, but I'll see what I can do. Also what tools will I be needing to find out if the issue is being caused by the pin you mentioned?
 

GTI's

Drag Race Newbie
Location
MD
You need to use a DVM to see if you have power (12v+) on Pin T4u/4 with the key on or the engine running. That Pin gets its power through the load reduction relay.

 

Hamad990

Passed Driver's Ed
Location
Winnipeg, Manitoba
Car(s)
2007 Golf GTi
GTI's And I have to do the testing at that pin right? Cause I was trying to take off the rear hatch panel and just could not do it. So im gonna try again after tomorrow when I have more time and its a bit warmer outside (It's getting to cold to work on the car these days so at this point im more or less at the mercy of the weather)
 

GTI's

Drag Race Newbie
Location
MD
There are other places to check but you still won't know if you are actually getting power to that Pin for the motor.
 
Top