GOLFMK7
GOLFMK6
GOLFMKV


  VW GTI Forum / VW Rabbit Forum / VW R32 Forum / VW Golf Forum - Golfmkv.com


 
Register
MYGOLF garage
Timeslips
Search
Members List
Search Today's Posts Mark Forums Read



Go Back   VW GTI Forum / VW Rabbit Forum / VW R32 Forum / VW Golf Forum - Golfmkv.com > Technical Discussions > Engine / Drivetrain / Exhaust
Uro Tuning

Reply
 
Thread Tools
Old 08-08-2011, 03:57 AM   #1
HereticByDefault
Formula 3000 Driver
 
HereticByDefault's Avatar
 
Drives: too high
Join Date: Oct 2008
Location: Chicago
Posts: 3,050
Weird Turbo Lag (Stage 2)

My car started acting up today, and was wondering if anyone may have insight as to what's going on.

Things I should mention before moving on:

-My PCV is f*cked (oil spewing out of oil cap). Just ordered the BSH revamp.

-I have fairly old spark plugs, so they may be bad by now. Have new ones ready to be put in tomorrow night.

-Last time I went in for service, VW dealer told me my throttle body needed to be replaced.

And now for the issue: I've only tried pulling in 2nd and 3rd gear since I noticed the problem, but the turbo does not fully spool until I hit 3000 RPM. It'll stay rock solid at 5 PSI all the way up, and then at 3k it will go right up to ~18 PSI with no fuss.

I'm not sure how long this has been going on as I don't push my car very often at all. I just got in the mood for some spirited driving tonight and it started acting up.

Any suggestions and insight on this issue would be much appreciated.

Thanks!
__________________
HereticByDefault is offline   Reply With Quote
Old 08-08-2011, 07:45 PM   #2
HereticByDefault
Formula 3000 Driver
 
HereticByDefault's Avatar
 
Drives: too high
Join Date: Oct 2008
Location: Chicago
Posts: 3,050
Almost 60 views and no opinions on this?

Last time this happened, it was a problem with my stock DV. Switched it out for the revision "D"
__________________
HereticByDefault is offline   Reply With Quote
Old 08-08-2011, 08:12 PM   #3
josein06gli
GLI OWNER
 
josein06gli's Avatar
 
Drives: 2006 GLI stage2+, 1989 MK2 GTI
Join Date: Sep 2009
Location: San Diego, Ca
Posts: 7,705
Get new throttlebody ? Change plugs, coil packs and seems like limp mode and boost leak somewhere. Stage 2 usually peaks 20-22psi
__________________
2006 BMP VW JETTA GLI DSG. APR Stage 2+ ATP DP/Autotech Catback/APR HPFP/BSH Intake/BSH FMIC/BSH VTA Catch Can/Forge DV/Full BSH Engine Mounts/KSport Control V4 Coilovers/VMR Wheels/Full Ice/Newsouth/
instagram: josein06gli
josein06gli is offline   Reply With Quote
Old 08-08-2011, 08:58 PM   #4
HereticByDefault
Formula 3000 Driver
 
HereticByDefault's Avatar
 
Drives: too high
Join Date: Oct 2008
Location: Chicago
Posts: 3,050
Yeah I'm pretty sure the PCV is what's causing the low boost after the lag. Just wasn't sure what was causing the lag itself. Figured limp mode would be a bit more restrictive.

Anyway, thanks for the response and suggestions!
__________________
HereticByDefault is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:10 AM.


Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.