PDA

View Full Version : VCDS (VAG-COM) rear fog light / reverse light coding, help needed


TDI_DSG
07-21-2009, 09:16 PM
Hi all.

some of you may know that i recently upgraded the CAN gateway in my car, to solve a power drain problem,
after the install of an RCD510.

anyway, the power drain is solved, but i now have a new problem.
im sure it's just a coding issue, but i have no clue.

here's the deal.

i now have no rear fog light, and i have a bulb out warning on the MFD.
reverse light still functions, as do all other lights. (i replaced the globe, just to make sure it's not a bad one)

in VCDS, if the fog light is set to one or two makes no difference.
even tried to disable the rear fog light, no difference.

the reverse lights are coded for two
if the reverse lights is set as one, then it stops working too.

currently the gateway is coded for two reverse lights (or i get no reverse light at all) and one fog light.

can someone please help ?

ps,
i don't have access to VCDS, the shop that did the gateway install does, but so far has been unable to figure it out.

if someone can tell me the correct module, and coding, i can get them to fix it.
or, if someone in the sydney area can look at it for me before Saturday that would be awesome.
im off to Brisbane for two weeks on sat morning.

Jason.

KWICKS
07-21-2009, 09:37 PM
Take it back to Derek seeing as though he was able to help you last time? Seemed a positive experience?

GTI_SS
07-21-2009, 10:11 PM
Agreed. I'd be taking it to Derek again, before getting a forum member to 'play' with it.

TDI_DSG
07-21-2009, 11:28 PM
That's where I was this morning.
He spent about an hour trying to figure it out.

That's why I posted here, as we didn't get any where with it.
Thought someone here might know the solution.

Jason

GTI_SS
07-21-2009, 11:35 PM
Haven't heard of that problem before on here.

Hopefully with the same model/spec can take some screen grabs for you to match too. Although it sounds like you've tried multiple coding possibilities, so I can't understand why.

Any reason why the light housing could be damaged and not only the bulb? Try swapping that section of the lamp out with someone else's and see if it's still a problem. Might help eliminate 1 more potential issue.

TDI_DSG
07-22-2009, 09:13 AM
ok, i have had some time to think about this now.

here's my take on what's going on.
VCDS reports an error code that's related to the "left rear fog light"
which is a little strange, as we have the fog on the right, not the left.

this also relates to the one versus 2 reverse lights setting.
on two, the reverse light works. on one, it does not.

on a lhd car, the reverse light would be on the right, so setting it to two, makes the left light on a rhd car work, but setting it to one, would have the opposite effect. as on a lhd car, the only reverse light would be on the right.

so im thinking that the gateway is coded for a left hook car.
is there some coding that tells the gateway what side the steering wheel is on ?

if there is, i think that will probably solve my problem.

Jason.

edit:

just found the solution (i think)
Byte 04 Bit 5 Model (0 = Right Hand Drive / 1 = Left Hand Drive)

heaps of info at this link too.....

coding info (http://en.openobd.org/vw/golf_1k.htm)

TDI_DSG
07-22-2009, 09:34 AM
Any reason why the light housing could be damaged and not only the bulb? Try swapping that section of the lamp out with someone else's and see if it's still a problem. Might help eliminate 1 more potential issue.

im 100 % certain it's related to the new gateway.
it was working when the old one was in, and as soon as the new one was installed, no go.

in my post above, i think i have found the solution.

as i didn't buy the gateway from VW australia, it was probably not set up for RHD, so Derek would not have thought to change it.

overall, im very happy with the service i have received from him, and will be going back for the next service.

Jason.

TDI_DSG
07-23-2009, 08:24 PM
Update:

problem solved.
spent some more time with Derek this morning, and found the problem.

in the can gateway module, byte 9 was not set as RHD.
once this was set to RHD, and the reverse light / fog lights set correctly, all problems gone.

all now function as expected, and no error codes present.

once again, i can not recommend Derek at European Autotech highly enough. top bloke, and top notch service too.

Jason.

Lams
07-23-2009, 10:49 PM
is young Bill still there :-)

GTI_SS
07-23-2009, 10:54 PM
I only know Adam. Also a top bloke.

Never knew of anyone called Bill. I've only been going there for the past year and a half though.

Their new website (http://www.europeanautotech.com.au) it up and running now too.

benough
07-24-2009, 12:13 AM
Shamless plug. So Embarrassing. :thumbdown:

:lol:

GTI_SS
07-24-2009, 12:14 AM
:middlefinger:

Lams
07-26-2009, 11:13 PM
Bill's the dog... Adam's not a bad bloke ;-)

TDI_DSG
07-26-2009, 11:19 PM
Yep, the "guard dog" was running about while I was there.

Cute little fella.

GTI_SS
07-26-2009, 11:49 PM
Ah yes. Bill the dog. My dog could learn a few manners from that boy.

happyalligator
06-16-2010, 11:32 AM
Can someone here give the exact byte and bit and control module that has be changed to return the car to a right hand drive in vcds?

I also upgraded the can bus gateway (from the F to AD version) and it all seems ok now, bar this one problem.

I have looked closely at byte 4 bit 5 of the central electronics control module (0 for rhd) and byte 9 bit 4 of the central convenience control module (1 for rhd), and even after playing with the vcds settings in general, the car still isn't expecting the fog light to be on the right hand side and the reverse light to be on the left (the correct positions in Australia).

Like the first post, the only way I've been able to get the rear lights to function normally is to enable both reverse lights and both rear fog lights.. of course, only 1 of each shows up on the rear, and on the instrumentation panel it warns of a broken light when the car turns on, but it's only complaining about the 'missing' reverse and rear fog lights.

Also, when it comes to changing the central electronics control module, I actually can't change the value of byte 4 bit 5 because it hasn't been defined in the long coding helper with a plain english definition and it shows the error message "out of range" if I try to change the coding on the displayed binary number. Is this what everyone else is also getting?

Thanks everybody...

TDI_DSG
06-16-2010, 10:27 PM
can't remember exactly where it was on mine.
but it was one box that needed to be ticked.

happyalligator
06-17-2010, 07:46 AM
OK thanks for the quick reply tdi_dsg, i'll have another look tonight for the mystery switch... i'm even considering switching the bulbs and lenses but found on google that its a legal requirement to keep the fog on the right and the reverse on the left

TDI_DSG
06-17-2010, 07:50 AM
just swapping the wiring won't solve the issue, as the car is still looking for bulbs that don't
exist.

happyalligator
06-17-2010, 10:02 AM
Found the right switch and it worked sweet!!

The switch is in the CAN gateway control module and it is in byte 09 bit 0 (bytes count from the left starting from 0, bits count from the right starting from 0). In the long coding helper its description is 'Right Hand Drive'.

To help out other newbies, the Installation List button only changes a part off the coding for the can bus gateway (in my version it only changes bytes 0-6 of the gateway's coding, and bytes 7-9 appear to be changed via the same Coding button also used for other control modules).

Screenshot of the switch to change is attached...


There is also another switch in byte 8 to define the brand and type of car, eg, Volkswagen Hatchback (which I had to change from the default Audi something).. doesn't seem to make any difference, but that's something else omitted from the Installation List button.

TDI_DSG
06-17-2010, 10:31 AM
glad you found it.

jonboy68
02-18-2012, 10:52 AM
Tnx for info:thumbsup:

Just a quick tip for noobs like myself....... dont forget to clear all the fault codes in vcds, otherwise ur dash lights up like a xmas tree n warning bleeps!.....i nearly crapped myself after performing the swap n software install lol.

TonyVas
06-10-2013, 07:41 AM
Hi, i having trouble with setting up GOLF MKV to RHD after i have purchased new door control modules & body control modules from Germany & i am in Australia, any help if possible would be appriecated

benough
06-10-2013, 08:18 AM
Go back 4 posts mate