PDA

View Full Version : EPC Light!!


nellaz31
04-06-2010, 03:50 PM
Since last week when ever I pressed or floor on the gas pedal up to 4000 RPM less than one minute my EPC light came on. It happened again this morning when I was about to drop off my car at VW Fairfax for my 40,000 miles service. My car turn off by itself even the battery light came on and when I started it again it was still on and my car didn't have power at all. Seems like it went to like a limp mode. I waited for a while about like 4 minutes and I turned back my car on, the light wasn't there anymore. I told the VW people about it and they checked it. They told me there is nothing wrong with it after they took it for a drive and floor it as well. This is weird. They also told me if this happens again just leave the light on light like that. Which doesn't make sense where if i leave it like that of course the light is not going to be there after a while.

What should I do people? I need help.

Mataleao9380
04-08-2010, 10:37 AM
I was going to make a thread about what just happened to me but found your thread instead--"search" ftw.

Here is what happened to me:
1. I was in the acceleration lane and needed to accelerate fast due to traffic. I floored it--I go to grab the next gear and BAM..I lose all power.
2. Car won't rev passed 30k rpms
3. EPC Light came on and ESP (traction control).
4. ESP will not cut back on/off
5. I get to my destination. I cut the car off and back on--car dies. I turn it over again, it starts--rough idle--the EPC turned off, then CEL came on--ESP stayed on.

Took it to the dealership and it was diagnosed as having an intermittent issue with the throttle body. Part is on order and will be replaced next week. Errors were cleared--car is back to normal.

krayzie089
04-08-2010, 10:54 AM
I was going to make a thread about what just happened to me but found your thread instead--"search" ftw.

Here is what happened to me:
1. I was in the acceleration lane and needed to accelerate fast due to traffic. I floored it--I go to grab the next gear and BAM..I lose all power.
2. Car won't rev passed 3k rpms
3. EPC Light came on and ESP (traction control).
4. ESP will not cut back on/off
5. I get to my destination. I cut the car off and back on--car dies. I turn it over again, it starts--rough idle--the EPC turned off, then CEL came on--ESP stayed on.

Took it to the dealership and it was diagnosed as having an intermittent issue with the throttle body. Part is on order and will be replaced next week. Errors were cleared--car is back to normal.

yeah i had that same problem with my throttle body about a year ago.For me it was a problem with the wiring harness that travels from my gas pedal to the throttle body. Took the dealership about a weeks worth of trial and error to figure it out too. Good luck man

krayzie089
04-08-2010, 10:58 AM
Since last week when ever I pressed or floor on the gas pedal up to 4000 RPM less than one minute my EPC light came on. It happened again this morning when I was about to drop off my car at VW Fairfax for my 40,000 miles service. My car turn off by itself even the battery light came on and when I started it again it was still on and my car didn't have power at all. Seems like it went to like a limp mode. I waited for a while about like 4 minutes and I turned back my car on, the light wasn't there anymore. I told the VW people about it and they checked it. They told me there is nothing wrong with it after they took it for a drive and floor it as well. This is weird. They also told me if this happens again just leave the light on light like that. Which doesn't make sense where if i leave it like that of course the light is not going to be there after a while.

What should I do people? I need help.

Next time it happens do not try to reset the the EPC light, leave it on as told. The dealership will just say everything is ok if there is nothing for them to scan. Its frustrating because they usually know what the issue is, but they will not do any warranty work unless they see a light on.

HondaSlayer
04-08-2010, 11:23 AM
my epc light came on a few times after I err....well ya know drove the shit out of my car. stupid shit'll get you run over if you don't notice it come on. Anyways, its like a ghost! If it comes on again drive it to the dealership! I hope I never see mine again.

TwinGTI
04-08-2010, 07:12 PM
I've been having similar issues with my car. I have APR stage 1 and love it but it seems to be giving me a lot of trouble.

I had the same issues a while back, I took it to the dealer and they ended up replacing my whole ECU. Bye Bye APR. Fast forward a few months.

I get APR reinstalled in my car and after two weeks my car is throwing up engine lights, EPC and even battery lights again.

Took it to AutoZone and they told me there was a throttle body issue.
I don't want to take it back to the dealer because they said if I reinstalled APR my warranty would be void *cough*Bullshit**cough*

Is the APR the problem or is it throttle body?

JaySki
04-08-2010, 07:50 PM
yeah i had that same problem with my throttle body about a year ago.For me it was a problem with the wiring harness that travels from my gas pedal to the throttle body. Took the dealership about a weeks worth of trial and error to figure it out too. Good luck man

I had the exact same problem. Warranty Work.

krayzie089
04-08-2010, 09:30 PM
I've been having similar issues with my car. I have APR stage 1 and love it but it seems to be giving me a lot of trouble.

I had the same issues a while back, I took it to the dealer and they ended up replacing my whole ECU. Bye Bye APR. Fast forward a few months.

I get APR reinstalled in my car and after two weeks my car is throwing up engine lights, EPC and even battery lights again.

Took it to AutoZone and they told me there was a throttle body issue.
I don't want to take it back to the dealer because they said if I reinstalled APR my warranty would be void *cough*Bullshit**cough*

Is the APR the problem or is it throttle body?

Im sure its your throttle body because ive been running APR stage 1 since last june with no problems once so ever. Clocked over 15k miles with oem DV and PVC still kicking. Now i have 41k on the ticker and its still fine.

TwinGTI
04-08-2010, 10:59 PM
Yeah that's what I think too, it just seems weird that when the APR was removed I didn't have any issue for two months. After two weeks of having the APR reinstalled I started having issues again.

Spoke with Chris from APR and he told me to take it to the dealer and ultimately that's what I'm gonna need to do but I'd like to get some more opinions first.

Mataleao9380
04-14-2010, 03:35 PM
Yeah--holy ****--it happened again but this time it almost made me **** my pants. I was on the acceleration lane once again, but this time I had just merged in when my car decided to go into hard limp mode--so from 60 to 40 to 20 in a matter of seconds--cars honking swerving behind me..eek. Car wouldnt rev passed 2000 rpms.

I had to pull over fast--I shut it off-turn it back on cel-epc-esc all on--idle sounded like i was driving a tractor--boost gauge showing 10 in HG. Turned it on off a few times--same issue.

I decided to limp it to the next exit. Popped the hood-disconnected the battery (read this trick on the forum somwhere)--turned it over--back to normal idle and 20 in hg (EPC off, Cel on ESC on).

Made it to the dealership fine. Argh.

rronan
05-06-2010, 11:25 PM
Im having a similar issue with a stage 2 tune on a MK6 I have the issue recorded and posted on you tube. Could any of you tell me if this is the same issue.

http://www.youtube.com/watch?v=RpLrYpxwF38

VW_gti_09
05-16-2011, 04:45 PM
this is happening to me now too tsi engine taking it in this friday (im a 4 hr drive from the nearest dealer)

EDGEMKV
05-17-2011, 01:32 AM
I was going to make a thread about what just happened to me but found your thread instead--"search" ftw.

Here is what happened to me:
1. I was in the acceleration lane and needed to accelerate fast due to traffic. I floored it--I go to grab the next gear and BAM..I lose all power.
2. Car won't rev passed 30k rpms
3. EPC Light came on and ESP (traction control).
4. ESP will not cut back on/off
5. I get to my destination. I cut the car off and back on--car dies. I turn it over again, it starts--rough idle--the EPC turned off, then CEL came on--ESP stayed on.

Took it to the dealership and it was diagnosed as having an intermittent issue with the throttle body. Part is on order and will be replaced next week. Errors were cleared--car is back to normal.

What part did you order? Did you have the throttle body replaced or was it something else that is located on the throttle body? (sensor, etc..)

JackMiracle
05-20-2011, 03:04 PM
Next time it happens do not try to reset the the EPC light, leave it on as told. The dealership will just say everything is ok if there is nothing for them to scan. Its frustrating because they usually know what the issue is, but they will not do any warranty work unless they see a light on.


I went in to do an oil change, and the engine light was on. It's been on for about a week and half, with the random EPC light thrown into the mix. So i was figuring the mechanic will turn on the car when they move it, and then do the check. So it turns out my whole throttle body is being replaced, under warranty. I hope this sorts out that damn EPC light too. I hate 'safe mode' in my car! But the thing is, VW needs to see that light. Use VW towing and get it to them in that condition!

I'll update everyone with the complete work list when i pick it up today. All i know, they said the estimated time would be 4-5 hours to fix the issue. I'm glad that's not coming out of my pocket !

VW_gti_09
05-21-2011, 01:36 AM
so i got it to the dealer, and yup...it was the throttle body...epc light came on twice and once the car shut off on me...funny thing is is the check engine never came on only the epc light but it was the throttle body and not everything is running fine! :) gotta love that factory warranty

grunt111
05-24-2011, 12:00 PM
Thats the same thing i went through at about only 10K on my 09 gti mk5 6speed. They had to change out the throttle body sensor and it was good to go. If you start hearing random clunk sounds on tight turns then tell them to re tighten the sub frame since this is a popular thing for these cars after break in.

VW_gti_09
05-24-2011, 01:03 PM
ya i told them about what was going on, they were abit amazed that the check engine light didnt turn on...and so am i..the whole car just dies on me on the high way and i costed it to a parking lot and let it sit for a bit then turned it back on and it started up like nothing....i had been feeling it jump alil at high speeds, but once i got to the like 50mph marker or below it would go away...any ways its running like a champ again
they didnt even care about my mods! i was a bit worried about that lol

JackMiracle
06-02-2011, 04:10 PM
I went in to do an oil change, and the engine light was on. It's been on for about a week and half, with the random EPC light thrown into the mix. So i was figuring the mechanic will turn on the car when they move it, and then do the check. So it turns out my whole throttle body is being replaced, under warranty. I hope this sorts out that damn EPC light too. I hate 'safe mode' in my car! But the thing is, VW needs to see that light. Use VW towing and get it to them in that condition!

I'll update everyone with the complete work list when i pick it up today. All i know, they said the estimated time would be 4-5 hours to fix the issue. I'm glad that's not coming out of my pocket !

VW replaced my throttle sensor, and that didn't work. Turns out I had a warped intake manifold - manufacturer defect. All replaced under warranty, and I talked them into detailing my car for free. It feels so good to have it back to normal again!

The Fed
06-04-2011, 12:36 PM
So exactly HOW did the dealer knew you had APR Stage 1? The only way is if you TOLD THEM!!

merkeyterkey
06-04-2011, 01:01 PM
Here is what happened to me:
1. I was in the acceleration lane and needed to accelerate fast due to traffic. I floored it--I go to grab the next gear and BAM..I lose all power.
2. Car won't rev passed 30k rpms


30K RPMS :eyebulge:

STORMIEE2.0T
10-04-2011, 10:50 PM
i have a mkv and i had the same problem Sunday right im just cruising on i95 doing 55 with c/c on went into the passing plane hit about 65 then car sputtered, soo i took my car to the vw dealer and they call me up today and tell me my turbo was blown:cry:! but its certified and although i have an 3" no cat or resignator they still did it under warranty... soo just go and get it check out and what ever u do dont clear the codes on your own because they wont take it..so u guys got the lucky end of the deal! Now time to invest in a turbo timer :thumbup:

VW_gti_09
10-05-2011, 02:37 AM
i have a mkv and i had the same problem Sunday right im just cruising on i95 doing 55 with c/c on went into the passing plane hit about 65 then car sputtered, soo i took my car to the vw dealer and they call me up today and tell me my turbo was blown:cry:! but its certified and although i have an 3" no cat or resignator they still did it under warranty... soo just go and get it check out and what ever u do dont clear the codes on your own because they wont take it..so u guys got the lucky end of the deal! Now time to invest in a turbo timer :thumbup:

these cars dont need turbo timers my friend.... the have an aux pump after the car shuts off that kicks in for that.. :) vw has already thought of that. search my friend search.:wink:

STORMIEE2.0T
10-05-2011, 09:55 PM
well thats the only thing i can think of that could have made my turbo blow.... idk but at least its gettin fixed so its cool! but thanks for that info

VW_gti_09
10-05-2011, 10:35 PM
well thats the only thing i can think of that could have made my turbo blow.... idk but at least its gettin fixed so its cool! but thanks for that info

np, just though id let ya know. it would be kinda a waste to buy a turbo timer. i mean you could if you wanted to but it would be a waste of money since there is a feature on the car that does that job any ways. best to use that money toward a tune:thumbsup: